slave_io_running: connecting 如何解决

 时间:2026-04-26 21:21:50

1、我敢肯定的并且排除的两个原因

1. 网络原因:在从库上拷贝主库上的备份文件的时候并没有出现任何的错误,因此可以排除。

2. POS 不对:这个我也可以排除,因为在主库上 show maste status 时我记录过了 POS,所以也将这个原因排除了。

2、很显然的问题是出现在 password 上面,只是我在从库上执行

CHANGE MASTER TO 

MASTER_HOST='192.168.223.101', 

MASTER_USER='liyao', 

MASTER_PASSWORD='liyao', 

MASTER_LOG_FILE='mysql-bin.000008', 

MASTER_LOG_POS= 261;

的时候 MASTER_PASSWORD='liyao', 中的 'liyao' 写成了 'liyao ',因此导致了从库上的 Slave_IO_Running: Connecting。

修改过后再来查看从库的状态,问题已经解决

  • 粉掌叶子发黄怎么回事
  • 归阳参怎么吃生精壮阳 教你五种最佳食用法
  • 你知道中国传统服装的发展历史吗?
  • 敷面膜过敏怎么办
  • 个性化用车需求来讲,现在买车买什么车比较好?
  • 热门搜索
    北京旅游图片 海边旅游城市 东钱湖旅游学校 广州好玩的旅游景点 巴厘岛旅游景点 英国旅游景点 广州旅游景点一日游 枫泾古镇旅游攻略 九寨沟旅游地图 欧洲旅游注意事项